Registering an IAuthenticationSchemeProvider service stops SAML working


We have recently registered a service into our identity provider (.NET Core) based on the IAuthenticationSchemeProvider interface. However, this has resulted in all SAML requests now failing with a 404 to the assertion consumer service. Taking out our IAuthenticationSchemeProvider service fixes the problem but obviously breaks the logic our service provided. I have tried registering the services in different orders but this has not worked - same result. Can you recommend any solutions to this problem or point me in the right direction?

Many thanks.

Just to confirm, your application is the IdP and when the SAML response is sent to the partner SP’s assertion consumer service this results in a 404?

Are you using the SAML middleware or calling the SAML API?

I’m not sure exactly how the IAuthenticationSchemeProvider is impacting SAML SSO but the two should be able to co-exist.

Are you able to reproduce the issue with the ExampleIdentityProvider and a test IAuthenticationSchemeProvider implementation?

If so, please zip up the source code and send it to so we can reproduce the issue and investigate further.